View Issue Details

IDProjectCategoryView StatusLast Update
0001033Far ManagerSymLink/HardLinkpublic2011-12-23 15:55
ReportertheultramageAssigned ToDrKnS 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0 
Target VersionFixed in Version3.0 
Summary0001033: relative path symlinks
DescriptionIn the alt+f6 'link' dialog, even if I enter a relative path, FAR will always create an absolute-path symlink. Hardlinks/junctions are probably affected as well (did not test).

Using the 'mklink' commandline utility in vista, I can create a relative-path symlink, which shows that it is indeed possible to achieve.
Additional InformationI guess FAR just normalizes the path before creating the link?
TagsNo tags attached.
Build2039

Activities

DrKnS

2009-09-04 20:09

administrator   bugnote:0004019

> I guess FAR just normalizes the path before creating the link?

Yes.

I think, we should leave path "as is" for symlinks, but not for junctions.

alexy

2011-12-23 14:20

administrator   bugnote:0008202

Is this still relevant?

DrKnS

2011-12-23 15:55

administrator   bugnote:0008214

AltF6 can't create relative symlinks by design, because you provide path for symlink object itself, not for it's target.

Relative symlinks can be created in Far3 via "Make Folder" function (F7).

Issue History

Date Modified Username Field Change
2009-09-04 11:30 theultramage New Issue
2009-09-04 20:09 DrKnS Note Added: 0004019
2010-02-15 20:09 alexy Status new => assigned
2010-02-15 20:09 alexy Assigned To => DrKnS
2011-12-23 14:20 alexy Note Added: 0008202
2011-12-23 15:55 DrKnS Build => 2039
2011-12-23 15:55 DrKnS Note Added: 0008214
2011-12-23 15:55 DrKnS Status assigned => closed
2011-12-23 15:55 DrKnS Resolution open => fixed
2011-12-23 15:55 DrKnS Fixed in Version => 3.0