View Issue Details

IDProjectCategoryView StatusLast Update
0001171Far ManagerViewerpublic2010-10-01 14:15
Reporterilyakharlamov Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformWindowsOSWindows 2003 Server 
Product Version2.0 
Summary0001171: Hex is shown incorrectly for some UTF-8 files
DescriptionWhen viewing some unicode files the internal Far's hex viewer shows hex characters incorrectly
Steps To Reproduce1. Open the file "WIREFAST42582-20-3395_properutf8.txt" in viewer (F3)
2. Switch to HEX mode (F4)
3. Go back to file browsing (Esc)
4. View the same file again (F3)

What is wrong:
The hex characters (at the left) are shown as E0 E0 E0 E0 E0 E0
TagsNo tags attached.
Build0

Activities

ilyakharlamov

2009-11-21 14:52

reporter  

WIREFAST42582-20-3395_properutf8.txt (4,783 bytes)   
<?xml version="1.0" ?>
<NewsML>
<Catalog Href="/catalog/zingzong.xml" />
<NewsEnvelope>
<TransmissionId>20091120-3773</TransmissionId>
<DateAndTime>20091120T1230+0000</DateAndTime>
<NewsProduct FormalName="" />
</NewsEnvelope>
<NewsItem>
<Identification>
<NewsIdentifier>
<ProviderId>fingerpost.co.uk</ProviderId>
<DateId>20091120</DateId>
<NewsItemId>MERCURY.WIREFAST2582.3773</NewsItemId>
<RevisionId PreviousRevision="0" Update="N">1</RevisionId>
<PublicIdentifier>urn:newsml:fingerpost.co.uk:20091120T1230:MERCURY.WIREFAST2582.3773:1</PublicIdentifier>
</NewsIdentifier>
</Identification>
<NewsManagement>
<NewsItemType FormalName="News"/>
<FirstCreated>20091120T123020+0000</FirstCreated>
<ThisRevisionCreated>20091120T123020+0000</ThisRevisionCreated>
<Status FormalName="Usable"/>
<Urgency FormalName="4"/>
</NewsManagement>
<NewsComponent EquivalentsList="no" Essential="yes" xml:lang="en">
<Role FormalName="Main" />
<NewsLines>
	<HeadLine>Ladbrokes: Jedward slashed to 16/1  from 50/1  to be axed from</HeadLine>
	<SubHeadLine />
	<ByLine>ROBIN HUTCHISON - LADBROKES</ByLine>
	<DateLine></DateLine>
	<KeywordLine>Ladbrokes: Jedward slashed to 16/1  from 50/1  to be axed from</KeywordLine>
</NewsLines>
<AdministrativeMetadata>
	<Provider><Party FormalName="MERCURY"/></Provider>
	<Source><Party FormalName="MERCURY"/></Source>
</AdministrativeMetadata>
<DescriptiveMetaData>
	<Language FormalName="en" />
</DescriptiveMetaData>
<Metadata>
	<MetadataType FormalName="ukIPTC7901"/>
	<Property FormalName="words" Value="410"/>
	<Property FormalName="category" Value="XXX"/>
	<Property FormalName="reference" Value=" "/>
</Metadata>
<Metadata>
	<MetadataType FormalName="Editorial"/>
	<Property FormalName="lib" Value="Sunday Mirror"/>
	<Property FormalName="pub" Value="Sunday Mirror"/>
	<Property FormalName="desk" Value="News"/>
	<Property FormalName="basket" Value="smnews"/>
	<Property FormalName="description" Value="SM Mercury News"/>
	<Property FormalName="life-in-days" Value="60"/>
	<Property FormalName="alert-group" Value=""/>
	<Property FormalName="formatted-indesign-tags" Value=""/>
</Metadata>
<NewsComponent EquivalentsList="no" Essential="yes" xml:lang="en">
<Role FormalName="Main Text" />
<ContentItem>
<MediaType FormalName="Text" />
<MimeType FormalName="text/plain" />

<DataContent>
<![CDATA[ATTN: Ladbrokes: Jedward slashed to 16/1 from 50/1 to be axed from RETURN OF THE JED?
JEDWARD are now 16/1 not to win X Factor but to go on and bag Christmas number one.
Ladbrokes chalked the pair up at a dismissive 50/1, but a huge gamble has seen the price cut through 40/1, 33/1, 25/1 and 20/1 into the present quote.
The duo, who are ahead of Cheryl Cole and Alexandra Burke in the Yuletide market, are 10/1, from 12/1, to win the show.
Ladbrokes spokesman, Nick Weinberg, said: “Jedward-mania continues to sweep the nation. Christmas cheer will be in short supply if they top the festive charts.”
 Lloyd Daniels is 8/11 to go this week, whilst Danyl is 5/1.
Soap star Ricky Whittle is 4/6 for Strictly success, with Gino D’Acampo 3/1, from 10/3, to be crowned king of the jungle.
LATEST BETTING
 X Factor
 Winner
 Olly Murs 2/1 
Stacey Soloman 5/2 
Joe McElderry 10/3 
Danyl Johnson 5/1 
John and Edward 10/1 
Lloyd Daniels 66/1
 Winning manager
 Simon Cowell evens 
Dannii Minogue 5/2 
Cheryl Cole 11/4 
Louis Walsh 10/1
 7th elimination
 Lloyd Daniels 8/11 
John and Edward 9/4 
Danyl Johnson 5/1 
Joe McElderry 16/1 
Stacey Solomon 20/1 
Olly Murs 25/1
 X Factor peak ratings- Nov 22
 Peak Ratings 16.7m or more 1/2 
Peak Ratings 16.6m or less 7/5
 Strictly Come Dancing
 Winner
 Ricky Whittle 4/6 
Ali Bastian 15/8 
Chris Hollins 10/1 
Jade Johnson 20/1 
Laila Rouass 20/1 
Natalie Cassidy 25/1 
Ricky Groves 66/1
 I’m A Celebrity
 Winner
 Gino D'Acampo 3/1 
Sam Fox 9/2 
Katie Price 5/1 
Jimmy White 7/1 
George Hamilton 10/1 
Lucy Benjamin 10/1 
Kim Woodburn 12/1 
Justin Ryan 16/1 
Colin McAllister 20/1 
Sabrina Washington 20/1 
Stuart Manning 25/1 
Joe Bugner 50/1
 Christmas number one (Radio One)
 Single
 X-factor winner 1/10 
Susan Boyle 8/1 
Michael Jackson 10/1 
John & Edward (Not as X Factor Winner) 16/1 
Cheryl Cole 20/1 
Alexandra Burke 25/1 
Boyzone 25/1 
JLS 25/1 
The Beatles 28/1 
Robbie Williams 40/1 
Take That 40/1 
Westlife 40/1 
Rihanna 50/1
 Album
 Susan Boyle 9/10 
Leona Lewis 2/1 
Take That 9/1 
Rihanna 10/1 
The Pope 12/1 
JLS 15/1 
Michael Jackson 10/1 
Robbie Williams 17/1 
Soldiers 17/1 
Westlife 17/1
 ends
Nick Weinberg
Ladbrokes Public Relations
 tel:020 8515 5458
mob: 07792 560 467
www.ladbrokes.com		
 MMMM
^SMNEWS
NEWSLINK 4026817W015 20NOV09 12:29/12:29 GMT 
FROM: ROBIN HUTCHISON - LADBROKES 
TO 19050010
]]>

</DataContent>
</ContentItem>
</NewsComponent>
</NewsComponent>
</NewsItem>
</NewsML>

ilyakharlamov

2009-11-21 14:52

reporter  

Screenshot.png (59,420 bytes)   
Screenshot.png (59,420 bytes)   

JohnDoe

2010-09-30 21:37

updater   bugnote:0005856

Duplicate of 0000752?

alexy

2010-09-30 21:58

administrator   bugnote:0005858

You seem to be using a very old Far version.

ilyakharlamov

2010-10-01 10:04

reporter   bugnote:0005862

2.0 (build 1086) x86 still reproducible

ilyakharlamov

2010-10-01 10:08

reporter   bugnote:0005863

2.0 (build 1666) x86 fixed

Issue History

Date Modified Username Field Change
2009-11-21 14:52 ilyakharlamov New Issue
2009-11-21 14:52 ilyakharlamov File Added: WIREFAST42582-20-3395_properutf8.txt
2009-11-21 14:52 ilyakharlamov File Added: Screenshot.png
2010-09-30 21:37 JohnDoe Note Added: 0005856
2010-09-30 21:58 alexy Note Added: 0005858
2010-09-30 21:59 alexy Status new => feedback
2010-10-01 10:04 ilyakharlamov Note Added: 0005862
2010-10-01 10:04 ilyakharlamov Status feedback => new
2010-10-01 10:08 ilyakharlamov Note Added: 0005863
2010-10-01 14:15 alexy Build => 0
2010-10-01 14:15 alexy Status new => closed
2010-10-01 14:15 alexy Resolution open => no change required