View Issue Details

IDProjectCategoryView StatusLast Update
0001563Far ManagerViewerpublic2011-03-22 00:15
Reporterzholobov Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindows 
Product Version2.0 
Summary0001563: Viewer highlights found string incorrectly
DescriptionWhen viewing a unicode file with BOM and searching for a string Far finds the string but highlights it incorrectly - with a 3 char offset to the left.
Steps To ReproduceIn Far 2.0.1666 x64 open attached file generic.xaml in viewer (F3). Search (F7) for string "Disabled" without quotes. Far finds the string, but highlights it with two char offset to the left. I.e. on line

<vsm:VisualState x:Name="Disabled">

it highlights text

="Disabl
Additional InformationSince BOM takes two bytes, it seems highlighting does not take BOM into account when calculating position. Probably if file contained some multibyte unicode characters this bug would be even worse.
TagsNo tags attached.
Build0

Relationships

duplicate of 0000786 closedvskirdin Неверное отображение найденного текста в файлах UTF-8 

Activities

zholobov

2010-11-01 09:13

reporter  

generic.xaml (200,895 bytes)

JohnDoe

2010-11-01 12:06

updater   bugnote:0005930

http://bugs.farmanager.com/view.php?id=786

Issue History

Date Modified Username Field Change
2010-11-01 09:13 zholobov New Issue
2010-11-01 09:13 zholobov File Added: generic.xaml
2010-11-01 12:06 JohnDoe Note Added: 0005930
2011-03-22 00:15 alexy Relationship added duplicate of 0000786
2011-03-22 00:15 alexy Build => 0
2011-03-22 00:15 alexy Status new => closed
2011-03-22 00:15 alexy Resolution open => duplicate