View Issue Details

IDProjectCategoryView StatusLast Update
0001708Far ManagerPanelpublic2013-04-25 17:01
Reportergrey.leoAssigned ToDrKnS 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindowsOS Version2003 SP2
Product Version2.0 
Target VersionFixed in Version3.0 
Summary0001708: Unexpected '.' and '..' subfolders
DescriptionThere are "visible" '.' folder for many "non-native" network shares.
Causing recursively delete/copy/find bug
Steps To ReproduceConnect to
 - "make available offline" network share
or
 - Novell CIFS network share
or
 - MS Virtual PC 2007 shared folder
Additional Informationhttp://forum.farmanager.com/viewtopic.php?f=9&t=6091
TagsNo tags attached.
Build2304

Relationships

duplicate of 0001654 closed extra "." and ".." in the directory panel 

Activities

dvv

2011-03-18 02:01

reporter   bugnote:0006539

Confirming the issue on Windows XP SP3 with Virtual PC shared folders

alexy

2011-12-23 12:24

administrator   bugnote:0008192

Should be fixed in 2304.

grey.leo

2011-12-23 13:41

reporter   bugnote:0008199

I've tried 2311 - many thanks!
But you make a side effect.
If share has structure like
\\server\share\dir\subdir
FAR 2311 can "CD" to "subdir" only, no any access to
\\server\share
 or even
\\server\share\dir

That is for Novell CIFS shares

grey.leo

2012-12-26 13:36

reporter   bugnote:0009903

Long time ago...
I can confirm that issue hasn't been solved.
FAR2 build 1666 shows '.' and double '..' on Novell CIFS shares, but FAR3 (and FAR2 build 1807) does not even CD to such share/mapped disk - "Access denied" "You need to provide administrator permission" subwindow pops up

Issue History

Date Modified Username Field Change
2011-02-07 11:14 grey.leo New Issue
2011-03-18 02:01 dvv Note Added: 0006539
2011-03-22 02:39 alexy Relationship added duplicate of 0001654
2011-12-23 12:24 alexy Note Added: 0008192
2011-12-23 12:24 alexy Assigned To => DrKnS
2011-12-23 12:24 alexy Status new => feedback
2011-12-23 13:41 grey.leo Note Added: 0008199
2011-12-23 13:41 grey.leo Status feedback => assigned
2012-12-26 13:36 grey.leo Note Added: 0009903
2013-04-25 17:01 alexy Build => 2304
2013-04-25 17:01 alexy Status assigned => closed
2013-04-25 17:01 alexy Resolution open => fixed
2013-04-25 17:01 alexy Fixed in Version => 3.0