View Issue Details

IDProjectCategoryView StatusLast Update
0001883Far ManagerEditorpublic2011-09-22 12:16
ReporterjdariasAssigned ToDrKnS 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version2.0 
Target VersionFixed in Version3.0 
Summary0001883: Spaces generated in editor when using numeric keypad
DescriptionWhen i use certain characters (/*-+. from the numeric keypad) at the begining of a sentence in the editor, instead of autocreating tab characters for indentation, FAR creates their equivalent in spaces. This is annoying, since it breaks the code layout when i see the file in another editor.
For example,

<script
[tab]function foo() {
[tab][tab]this.foo=5;
··········// These slashes create a space indentation instead of tabs because they came from the numeric keypad.
··········// And they will propagate to other lines, because of autoindentation.
[tab][tab]//If i create them with the alphanumeric keyboard, normal tabs appear.
[tab]}
</script
Steps To Reproduce1. Activate autoindentation in the FAR editor.
2. Go to the editor, and type tab to indent the line. Write something.
3. Press return and type any of these characters from the numeric keypad / * - + .
4. Activate show whitespaces in the editor: you´ll see that instead of creating tabs to indent the line, the editor has created spaces.
TagsNo tags attached.
Build2201

Activities

DrKnS

2011-09-22 12:16

administrator   bugnote:0007728

build 2201.

Issue History

Date Modified Username Field Change
2011-09-16 05:28 jdarias New Issue
2011-09-22 12:16 DrKnS Build => 2201
2011-09-22 12:16 DrKnS Note Added: 0007728
2011-09-22 12:16 DrKnS Status new => closed
2011-09-22 12:16 DrKnS Assigned To => DrKnS
2011-09-22 12:16 DrKnS Resolution open => fixed
2011-09-22 12:16 DrKnS Fixed in Version => 3.0