View Issue Details

IDProjectCategoryView StatusLast Update
0002083Far ManagerInterfacepublic2012-04-29 22:36
ReporterDAtaManAssigned To2useven10 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002083: В отфильтрованном меню нажатие Home перемещает курсор в конец
DescriptionВ любом меню/истории при включённом и не пустом фильтре Home перемещает курсор на последний элемент.

А иногда курсор вообще не перемещается.
Steps To ReproduceF9 Enter Ctrl-Alt-F - f Home
TagsNo tags attached.
Build2651

Relationships

duplicate of 0002091 closed2useven10 В меню не работает кнопка Home 

Activities

DAtaMan

2012-04-23 17:59

reporter   bugnote:0009024

В b2605 ещё всё нормально, а вот после...

DAtaMan

2012-04-24 11:36

reporter   bugnote:0009043

Last edited: 2012-04-24 11:40

View 3 revisions

Поломалось, видимо, после этого: (сам пока проверить не могу)
drkns 12.04.2012 09:55:30 +0200 - build 2608
2. Уточнение 2604.1.

vmenu.cpp, 294
было int Ret = SetSelectPos(ListPos->SelectPos,1);
стало int Ret = SetSelectPos(ListPos->SelectPos,ListPos->SelectPos > SelectPos? 1 : -1);

DAtaMan

2012-04-29 14:18

reporter   bugnote:0009078

Решено в b2651

Issue History

Date Modified Username Field Change
2012-04-23 17:41 DAtaMan New Issue
2012-04-23 17:59 DAtaMan Note Added: 0009024
2012-04-24 11:36 DAtaMan Note Added: 0009043
2012-04-24 11:37 DAtaMan Note Edited: 0009043 View Revisions
2012-04-24 11:40 DAtaMan Note Edited: 0009043 View Revisions
2012-04-29 12:20 2useven10 Relationship added duplicate of 0002091
2012-04-29 14:18 DAtaMan Note Added: 0009078
2012-04-29 14:18 DAtaMan Status new => resolved
2012-04-29 22:36 2useven10 Build => 2651
2012-04-29 22:36 2useven10 Status resolved => closed
2012-04-29 22:36 2useven10 Assigned To => 2useven10
2012-04-29 22:36 2useven10 Resolution open => fixed
2012-04-29 22:36 2useven10 Fixed in Version => 3.0