View Issue Details

IDProjectCategoryView StatusLast Update
0002247Far ManagerFindFilespublic2013-02-01 15:09
ReportershezgareAssigned Toalexy 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002247: Search by Alt-F7: if substring entered, file mask is ignored
DescriptionFile and archive manager 3.0 build 3067 x86

If substring is entered, file mask is ignored.
Without substring file mask works.
Steps To ReproducePress Alt-F7
"A file mask or several file masks:"
*.sql

"Containing text:"
scanstatus

Search goes by all files
TagsNo tags attached.
Build3137

Activities

shmuel

2013-01-10 14:54

developer   bugnote:0009957

> If substring is entered, file mask is ignored.

Can you prove that statement? Does the search really *finds* files with the wrong mask and places them in "Find file" window?

shezgare

2013-01-11 13:06

reporter   bugnote:0009964

I can make videofile if you wish.
The search searches all files. But returns results in files with correct mask.
But it really scans all files, which takes very long.
*
For example: I'm not an Admin on my computer, and if I search for *.sql with no substring, it's ok.
But when substring entered, FAR starts asking for permissions on files in system folders ans so on, which is also annoying.
*
Should I make a video?

shmuel

2013-01-11 13:28

developer   bugnote:0009965

No need in videofile. I understand what seems confusing to you: file names displayed in the dialog as the search is working. But that does NOT mean Far Manager opens and reads those files.

It however does check the _names_ of ALL files against the mask, because the Far-style masks are much more flexible and powerful than native Windows masks (you can specify multiple masks at once, you can specify masks to exclude from the search, you can specify mask as regular expression).

I just did a search by inexistent mask "*.a8b" with substring "a" to search on my C: drive (50 GB). The first search took 60 sec., the second search took 1 sec. Such speed would not be possible if Far was searching inside files.

DrKnS

2013-01-11 13:30

administrator   bugnote:0009966

> file names displayed in the dialog as the search is working

We need to fix that, it confuses me too.

shezgare

2013-01-11 14:59

reporter   bugnote:0009967

Which confuses me, Far starts asking for permissions to access *all* files.
Maybe it just ascs for access, but doesn't open and read them, but why it tries to access them?
And why doesn't try to access when searching without substring?

There's difference in attempt to access files when searching with or without substring. It's a fact.

alexy

2013-01-31 04:03

administrator   bugnote:0010165

Fixed progress display - build 3137.
Otherwise there is no other issue with incorrect file access and so on.

Issue History

Date Modified Username Field Change
2013-01-10 13:26 shezgare New Issue
2013-01-10 14:54 shmuel Note Added: 0009957
2013-01-11 13:06 shezgare Note Added: 0009964
2013-01-11 13:28 shmuel Note Added: 0009965
2013-01-11 13:30 DrKnS Note Added: 0009966
2013-01-11 14:59 shezgare Note Added: 0009967
2013-01-31 04:03 alexy Note Added: 0010165
2013-01-31 04:03 alexy Assigned To => alexy
2013-01-31 04:03 alexy Status new => feedback
2013-02-01 15:09 alexy Build => 3137
2013-02-01 15:09 alexy Status feedback => closed
2013-02-01 15:09 alexy Resolution open => fixed
2013-02-01 15:09 alexy Fixed in Version => 3.0