View Issue Details

IDProjectCategoryView StatusLast Update
0002403Far ManagerDelete files/folderspublic2013-05-07 23:51
ReporterflorinfaurAssigned To2useven10 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002403: Current file after deletion
DescriptionThe current file (on which is the cursor) is not the next one after deleting some files with Shift+F8.
Steps To ReproduceSteps to reproduce:
1. In one folder select several files in such a way that there are files not selected after the selected ones. For example if in the folder there are 3 files 1.txt, 2.txt, and 3.txt, then select only 1.txt and 2.txt.

2. Go with the cursor on the first file, in the example on the file 1.txt

3. Using Shift+F8 delete the current file. Only the first file is deleted. The files 2.txt and 3.txt remain on the disk and 2.txt is still selected.

The problem is that the current file becomes 3.txt (the first file that is not selected) instead of 2.txt as it would be logical and how it worked a few released ago.
If all the files are selected (or there are no more selected files after the selected group), deleting only one of the files makes the next file to be current.
TagsNo tags attached.
Build3376

Activities

2useven10

2013-04-30 09:08

developer   bugnote:0010925

3376

Issue History

Date Modified Username Field Change
2013-04-30 03:10 florinfaur New Issue
2013-04-30 09:08 2useven10 Note Added: 0010925
2013-04-30 09:08 2useven10 Assigned To => 2useven10
2013-04-30 09:08 2useven10 Status new => feedback
2013-05-07 23:51 2useven10 Build => 3376
2013-05-07 23:51 2useven10 Status feedback => closed
2013-05-07 23:51 2useven10 Resolution open => fixed
2013-05-07 23:51 2useven10 Fixed in Version => 3.0