View Issue Details

IDProjectCategoryView StatusLast Update
0002409Far ManagerCopy/Movepublic2013-05-16 01:47
ReporterJustMeAssigned Toalexy 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version8
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002409: FAR crashes when moving a directory (even with no plugin)
DescriptionFAR crashes when moving a directory
Steps To ReproduceClick on a directory, hit F6 and try to move it to the other panel's directory.
Additional InformationThe directory is moved before the crash occurs.

FAR 3.0.3387 x64 displays:
Exception: Access violation (read from 0x0000000006DA2044)
Address: 0x000007F725D43597
Function: wmain
Module: C:\Program Files\Far\Far.exe
TagsNo tags attached.
Build3410

Activities

alexy

2013-05-12 12:25

administrator   bugnote:0010968

Can you enable fexcept and provide a crashdump log?
And also try this in latest Far build, I can't reproduce this.

JustMe

2013-05-12 12:28

reporter   bugnote:0010969

Last edited: 2013-05-12 13:39

View 5 revisions

I'll try...

Hmm... where can I find latest x64 FExcept? It seems to be only available in the x86 package.

I could reproduce it in the x86 version as well. Happens already when renaming a 137-char-long directory to a 138-char-long directory - the length of the full name is important like "C:\User\myname\test\this and that\..."

How to enable FExcept in x86 version? Techinfo.txt says it's enabled by default. But I always get the Exception occured dialog with no message like generating log file.

2useven10

2013-05-13 17:06

developer   bugnote:0010975

Can you provide full source/target path that crashes your system ?

alexy

2013-05-13 17:40

administrator   bugnote:0010976

far.exe /import FExcept\SetFarExceptionHandler.farconfig

JustMe

2013-05-14 22:36

reporter   bugnote:0010982

Last edited: 2013-05-14 22:37

View 2 revisions

@alexy: Doesn't work. Starting from within a running instance I can't see any error message. It just quits immediately with that parameter.

@2useven10: Being in "C:\Users\abcd\Downloads\Dies ist ein ganz langer Test eines Verzeichnisnamens"
renaming another dir "bug" to "bugs" works fine.
Renaming "bugs" to "bug" chrashes Far.

alexy

2013-05-14 22:55

administrator   bugnote:0010984

It doesn't crash for me.

It should quit immediately, the important thing is to run it from the folder where far is installed and verify that you actually have FExcept\SetFarExceptionHandler.farconfig there.
Then (and this is only for the x86 version) when far crashes it should generate a crash log in %farlocalprofile%\CrashLogs

JustMe

2013-05-15 00:02

reporter   bugnote:0010985

You have to run it like "far /import:FExcept\..." with a colon.

Any way, now here's the crash log.

JustMe

2013-05-15 00:02

reporter  

FarTrap_20130514215553.log (60,829 bytes)

alexy

2013-05-15 00:10

administrator   bugnote:0010986

I ensure it that it doesn't need to be run with a colon, and doesn't work that way in any case. But nevermind, will have a look at the log.

alexy

2013-05-15 00:49

administrator   bugnote:0010988

Should be fixed in 3410.

JustMe

2013-05-15 01:05

reporter   bugnote:0010989

Last edited: 2013-05-15 01:06

View 2 revisions

Thank you! Will try this as soon as the binary becomes available.

But I can also confirm "/import file" does not work where as "/import:file" did the trick (currently using build 3402).

Can you shed some light on what was wrong causing the crash?

alexy

2013-05-15 01:27

administrator   bugnote:0010990

the import works, you just needed to restart far.
/import: just started a new copy of far and that is why you though it worked.

Anyway, there was a bug in updating the tree cache file. That is why we couldn't reproduce it because we don't really use the tree feature.

JustMe

2013-05-16 00:28

reporter   bugnote:0010992

I can't produce a crash with 3410 right now... great, thank you very much!

Issue History

Date Modified Username Field Change
2013-05-11 18:25 JustMe New Issue
2013-05-12 12:25 alexy Note Added: 0010968
2013-05-12 12:28 JustMe Note Added: 0010969
2013-05-12 12:52 JustMe Note Edited: 0010969 View Revisions
2013-05-12 12:55 JustMe Note Edited: 0010969 View Revisions
2013-05-12 13:20 JustMe Note Edited: 0010969 View Revisions
2013-05-12 13:39 JustMe Note Edited: 0010969 View Revisions
2013-05-13 17:06 2useven10 Note Added: 0010975
2013-05-13 17:40 alexy Note Added: 0010976
2013-05-14 22:36 JustMe Note Added: 0010982
2013-05-14 22:37 JustMe Note Edited: 0010982 View Revisions
2013-05-14 22:55 alexy Note Added: 0010984
2013-05-15 00:02 JustMe Note Added: 0010985
2013-05-15 00:02 JustMe File Added: FarTrap_20130514215553.log
2013-05-15 00:10 alexy Note Added: 0010986
2013-05-15 00:28 alexy Assigned To => alexy
2013-05-15 00:28 alexy Status new => assigned
2013-05-15 00:49 alexy Note Added: 0010988
2013-05-15 00:49 alexy Status assigned => feedback
2013-05-15 01:05 JustMe Note Added: 0010989
2013-05-15 01:05 JustMe Status feedback => assigned
2013-05-15 01:06 JustMe Note Edited: 0010989 View Revisions
2013-05-15 01:27 alexy Note Added: 0010990
2013-05-16 00:28 JustMe Note Added: 0010992
2013-05-16 01:45 alexy Build => 3410
2013-05-16 01:45 alexy Status assigned => closed
2013-05-16 01:47 alexy Resolution open => fixed
2013-05-16 01:47 alexy Fixed in Version => 3.0