View Issue Details

IDProjectCategoryView StatusLast Update
0002566Far ManagerEditorpublic2016-04-30 23:42
ReportertheultramageAssigned ToDrKnS 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002566: unwanted tabs inserted when moving through file
DescriptionWhen moving through a file, certain keypresses cause empty lines to be auto-indented with tabs to the current cursor position. This means tabs are silently inserted into the file.

I edit source code in Far Manager often, and this behavior causes unwanted extra changes. Before every commit I check 'svn diff' to clean up all these stray tabs, and it's really annoying.

Note that even if these extra tabs are inserted, if you exit the editor without saving (F2), you will not be prompted about unsaved changes. This makes me believe this whole behavior is a bug and not something intentional.
Steps To Reproduce(steps assume auto-indent is off)
Open new file.
Press 'tab'.
Type "test".
Press 'enter' to make newline below our text.
Press 'up' then 'right' to position the cursor at the beginning of the text.
Save file.

Press 'down'. Notice that we're on "col 9 ch 9".
example 1)
Press 'end' (numpad 1). Notice that we're suddenly on "col 9 ch 2".
example 2)
Press 'left'. Notice that we're on "col 8 ch 8".
Press 'right'. Notice that we're suddenly on "col 9 ch 2".

In both cases the line gets auto-indented with tabs.
Additional InformationThis has existed at least since r10386 (build 3431, May 28, 2013).
Tested on a clean default install in WinXP VM.
TagsNo tags attached.
Build4491

Relationships

has duplicate 0003143 closedDrKnS При движении стрелками в редакторе добавляются пробелы 

Activities

shmuel

2014-01-17 19:20

developer   bugnote:0011701

> This has existed at least since r10386 (build 3431, May 28, 2013).

This exists in build 2325.
This does not exist in build 2066.

2useven10

2014-01-17 21:38

developer   bugnote:0011702

trunk (3776) -- can't reproduce.

shmuel

2014-01-17 21:45

developer   bugnote:0011704

Last edited: 2014-01-17 21:46

View 2 revisions

3776 -- it reproduces always for me.

theultramage

2014-01-18 00:16

reporter   bugnote:0011705

Last edited: 2014-01-18 00:16

View 2 revisions

Bisection result: revision 6719 (build 2201)
r6719: https://code.google.com/p/farmanager/source/detail?r=6719
#1883: http://bugs.farmanager.com/view.php?id=1883

theultramage

2014-01-18 00:27

reporter   bugnote:0011706

I think what's happening is:
When you position the cursor past end of line and then start typing, Far will fill in the gap to the left using tabs (or spaces?). That sounds right.
Bug #1883 complained that when you use certain numpad keys (/*-+), the gap is filled with spaces instead of tabs. The commit did some re-factoring, and apparently introduced a defect where ALL numpad keys are considered as typed-in text, even movement arrow keys.
So that commit causes numpad movement keys to trigger auto-indentation. I confirmed that using the small arrow keys does not cause this problem.

2useven10

2014-01-18 00:35

developer   bugnote:0011707

Last edited: 2016-04-30 22:47

View 2 revisions

Yes, reproduced. I didn't pay attention to NUMPAD...

theultramage

2016-04-30 22:40

reporter   bugnote:0014521

This was fixed sometime in the recent past. No longer reproduces on r13886 build 4567.

Issue History

Date Modified Username Field Change
2014-01-17 18:48 theultramage New Issue
2014-01-17 19:20 shmuel Note Added: 0011701
2014-01-17 21:38 2useven10 Note Added: 0011702
2014-01-17 21:45 shmuel Note Added: 0011704
2014-01-17 21:46 shmuel Note Edited: 0011704 View Revisions
2014-01-18 00:16 theultramage Note Added: 0011705
2014-01-18 00:16 theultramage Note Edited: 0011705 View Revisions
2014-01-18 00:27 theultramage Note Added: 0011706
2014-01-18 00:35 2useven10 Note Added: 0011707
2016-04-30 22:40 theultramage Note Added: 0014521
2016-04-30 22:47 2useven10 Note Edited: 0011707 View Revisions
2016-04-30 23:41 DrKnS Relationship added has duplicate 0003143
2016-04-30 23:42 DrKnS Build => 4491
2016-04-30 23:42 DrKnS Status new => closed
2016-04-30 23:42 DrKnS Assigned To => DrKnS
2016-04-30 23:42 DrKnS Resolution open => fixed
2016-04-30 23:42 DrKnS Fixed in Version => 3.0