View Issue Details

IDProjectCategoryView StatusLast Update
0002600Far ManagerPlugins Managerpublic2014-02-14 21:34
ReporterxarxAssigned ToDrKnS 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002600: Far doesn't load plugins with the same dll-name
DescriptionWhen having several plugins with the same name of their dll, only the first one gets loaded. When trying to load the others manually (via Ctrl-L in PlugMenu plugin), I get "Plugin load error".
Steps To ReproduceRename DLLs of at least two plugins to the same name (say Plugin.dll), and then run the Far. Only one of the plugins gets loaded.
Additional InformationThis problem occurs since the build Far30b3749.x86.20131231.7z.
In the build Far30b3747.x86.20131230.7z it still worked fine.

The consequence of this problem is, that after upgrading Far, some plugins might stop working without an evident reason. That's why I denoted this problem with the major severity.
TagsNo tags attached.
Build3808

Activities

shmuel

2014-02-14 15:15

developer   bugnote:0011831

Plugins with the same name are still loaded (and work) but only one of them appears in the plugins menu. Nevertheless, it is a serious bug, I agree.

xarx

2014-02-14 15:21

reporter   bugnote:0011832

In my case they do not work. I have many plugins loaded with Far3Wrap loader.dll, and only one works. If I renamed to loader.dll e.g. the SortStr plugin, it stopped working too.

Issue History

Date Modified Username Field Change
2014-02-14 15:07 xarx New Issue
2014-02-14 15:15 shmuel Note Added: 0011831
2014-02-14 15:19 shmuel Category Plugins API => Plugins Manager
2014-02-14 15:21 xarx Note Added: 0011832
2014-02-14 15:37 shmuel Steps to Reproduce Updated View Revisions
2014-02-14 21:32 DrKnS Assigned To => DrKnS
2014-02-14 21:32 DrKnS Status new => assigned
2014-02-14 21:34 DrKnS Build => 3808
2014-02-14 21:34 DrKnS Status assigned => closed
2014-02-14 21:34 DrKnS Resolution open => fixed
2014-02-14 21:34 DrKnS Fixed in Version => 3.0