View Issue Details

IDProjectCategoryView StatusLast Update
0002937PluginsNetBoxpublic2015-02-10 17:01
ReporterLigHAssigned To2useven10 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version 
Summary0002937: NetBox crashes silently after FTP listing with symlinks
DescriptionNetBox 2.1.41.365 (shipped with Far manager v3.0.4242 x64 as recent "stable") apparently crashes in one specific of many FTP sessions I use. After logging in, it lists a lot of directories and files. There are also directories created as symbolic links.

When I try to change into a directory, or even get back to the sessions list (selecting '..' or pressing Ctrl+PgUp), the panel gets reverted to the local file system view. There is no error message. NetBox probably crashed already right after updating the panel listing, calling the viewer (F3) does nothing, copying a file (F5) shows the local file system as well, instead of the copy dialog of NetBox.

NetBox 2.1.39.320 (shipped with Far manager v3.0.4040 x64 as previous "stable") can handle this situation.

When I turn off the option "Resolve symbolic links" for this FTP session, NetBox survives.
Steps To Reproduce1. Select NetBox in a Far manager panel
2. Log in into a normal FTP session with password, where resolving symlinks is enabled
3. The directory content is listed in the panel, linked directories appear as
4. Try to change into a directory
5. NetBox seems to close silently, the local file system is displayed in the panel

Unfortunately I can't share access details to this FTP server...
TagsNo tags attached.

Relationships

duplicate of 0002884 closedmichael.lukashov Не может сменить каталог, если в текущем каталоге есть симлинк 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-02-10 16:47 LigH New Issue
2015-02-10 17:00 2useven10 Relationship added duplicate of 0002884
2015-02-10 17:01 2useven10 Status new => closed
2015-02-10 17:01 2useven10 Assigned To => 2useven10
2015-02-10 17:01 2useven10 Resolution open => duplicate