View Issue Details

IDProjectCategoryView StatusLast Update
0002953Far ManagerPanel.Treepublic2016-01-17 13:40
ReporterLigHAssigned ToDrKnS 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0002953: When the tree3.far cache file exists, calling the tree dialog (Alt-F10) crashes Far manager
DescriptionAbout since Far manager version 3.0.4242 (not yet in 4040), as soon as the tree3.far cache file exists, the Far manager crashes when the tree view dialog is called by pressing Alt+F10 (and while the cache file is created, it crashes as soon as reading the tree finished).

There is no crash loading the tree into the other panel by pressing Ctrl+T.
Steps To ReproducePress Alt+F10.
Additional InformationCrash details from Far manager v3.0.4269:

Exception: Access violation (Read from 0x0000000000000092)
Address: 0x000000013FCDAB90
Function: mainImpl
Module: C:\Program Files\Far Manager\Far.exe


Crash details from Far manager v3.0.4278:

Address: 0x000000013FC5A110


Crash details from Far manager v3.0.4242:

Address: 0x000000013FE99510
TagsNo tags attached.
Build4512

Activities

DrKnS

2016-01-14 22:25

administrator   bugnote:0014202

Can you attach here the cache file which causes crash?

LigH

2016-01-15 10:32

reporter   bugnote:0014204

Last edited: 2016-01-15 10:43

View 6 revisions

Well, in fact, it seems not to be the content of the cache file. It is identical to a cache file created by Far2. With the same cache file, Far v3.0.4040 does not crash. The building part (reading the directory structure from the partition and writing it into the file) appears to be the stable part. So I believe that the issue is after reading the cache content, while displaying it or preparing for that. I have disks with several partitions, and the crash happens on every partition where Far would store a cache file in the root.

Current access violation (reading of 0x0...088) addresses are (always in mainImpl):

v3.0.4505.x64 (stable): 0x000000013F27A4B5
v3.0.4509.x64 (nightly): 0x000000013FDFE615

Trying to continue a crashed Far results in an exit with crash report on the console, for v3.0.4509: Access violation reading from 0x0...0188 in wmain @ 0x000000013FC9E5C5.

Displaying the tree in a left/right panel (instead of the directory content) does not crash. Only the (almost full-screen) tree navigation dialog crashes.

DrKnS

2016-01-16 06:19

administrator   bugnote:0014209

Last edited: 2016-01-16 06:19

View 2 revisions

Please try to pick this build: http://farmanager.com/farbugs/M3079_Release.64.vc.7z , unpack it somewhere (including the far.pdb) and try to reproduce your issue with it.
In case of crash there will be a 'Stack' button, press it and post the results here.

LigH

2016-01-16 08:23

reporter   bugnote:0014212

This produced the following stack trace:

0: 000000013FEB8778 printStack - 0x5367367248
1: 000000013FEB8D36 StackLogger - 0x5367368896
2: 0000000077879F7F vsprintf_s - 0x2005376596
3: 00000000778788A2 RtlUnwindEx - 0x2005368912
4: 00000000778AD948 KiUserExceptionDispatcher - 0x2005588250
5: 000000013FE39715 Panel::Show - 0x5366847152
6: 000000013FDC8F17 FolderTree::DisplayObject - 0x5366386256
7: 000000013FE96B9C ScreenObject::Show - 0x5367229184
8: 000000013FE211FE std::_For_each<std::tr1::shared_ptr<window> const * __ptr64,`anonymous namespace'::<lambda13> 
> - 0x5366747600
9: 000000013FE1DD8C `anonymous namespace'::<lambda11>::operator() - 0x5366734128
10: 000000013FE1DCE7 Manager::RefreshCommit - 0x5366733904
11: 000000013FE1DC32 Manager::ActivateCommit - 0x5366733552
12: 000000013FE1DDE6 Manager::ExecuteCommit - 0x5366734256
13: 000000013FE19BB2 MessageOneWindow::Process - 0x5366717328
14: 000000013FE1D502 Manager::Commit - 0x5366731888
15: 000000013FE1AF7D Manager::ExecuteModal - 0x5366722368
16: 000000013FDC8DEF FolderTree::init - 0x5366385200
17: 000000013FDC8A1E FolderTree::create - 0x5366385088
18: 000000013FC813BE CommandLine::ProcessKey - 0x5365042160
19: 000000013FDA6DD2 FilePanels::ProcessKey - 0x5366239392
20: 000000013FE1D0C7 Manager::ProcessKey - 0x5366729840
21: 000000013FE1C896 Manager::ProcessMainLoop - 0x5366728352
22: 000000013FE1C680 Manager::EnterMainLoop - 0x5366728256
23: 000000013FE15EA9 MainProcess - 0x5366700192
24: 000000013FE18ED3 mainImpl - 0x5366708864
25: 000000013FE1938F wmain - 0x5366714912
26: 000000013FEF36D7 __tmainCRTStartup - 0x5367608732
27: 0000000077655A4D BaseThreadInitThunk - 0x2003130944
28: 000000007788B831 RtlUserThreadStart - 0x2005448720

DrKnS

2016-01-16 12:53

administrator   bugnote:0014213

The problem was actually in [x] Always show the menu bar.

Fixed in 4512.

LigH

2016-01-16 13:03

reporter   bugnote:0014214

Crazy... Thank you!

abelenki

2016-01-17 07:36

reporter   bugnote:0014220

Last edited: 2016-01-17 08:04

View 6 revisions

i also had this crash when enabling Panel.Tree and pressing Alt+F10.

and i also had this option:

[x] Always show the menu bar


i just tested it again in 4512, and it works fine now. thanks!

Issue History

Date Modified Username Field Change
2015-02-26 13:28 LigH New Issue
2015-02-26 17:01 2useven10 Category Dialog => Panel.Tree
2016-01-14 22:25 DrKnS Note Added: 0014202
2016-01-15 10:32 LigH Note Added: 0014204
2016-01-15 10:33 LigH Note Edited: 0014204 View Revisions
2016-01-15 10:38 LigH Note Edited: 0014204 View Revisions
2016-01-15 10:39 LigH Note Edited: 0014204 View Revisions
2016-01-15 10:43 LigH Note Edited: 0014204 View Revisions
2016-01-15 10:43 LigH Note Edited: 0014204 View Revisions
2016-01-16 06:19 DrKnS Note Added: 0014209
2016-01-16 06:19 DrKnS Note Edited: 0014209 View Revisions
2016-01-16 08:23 LigH Note Added: 0014212
2016-01-16 12:53 DrKnS Note Added: 0014213
2016-01-16 12:53 DrKnS Assigned To => DrKnS
2016-01-16 12:53 DrKnS Status new => feedback
2016-01-16 13:03 LigH Note Added: 0014214
2016-01-16 13:03 LigH Status feedback => assigned
2016-01-17 07:36 abelenki Note Added: 0014220
2016-01-17 07:38 abelenki Note Edited: 0014220 View Revisions
2016-01-17 08:01 abelenki Note Edited: 0014220 View Revisions
2016-01-17 08:02 abelenki Note Edited: 0014220 View Revisions
2016-01-17 08:02 abelenki Note Edited: 0014220 View Revisions
2016-01-17 08:04 abelenki Note Edited: 0014220 View Revisions
2016-01-17 13:40 DrKnS Build => 4512
2016-01-17 13:40 DrKnS Status assigned => closed
2016-01-17 13:40 DrKnS Resolution open => fixed
2016-01-17 13:40 DrKnS Fixed in Version => 3.0