View Issue Details

IDProjectCategoryView StatusLast Update
0003106Far ManagerFindFilespublic2015-10-27 02:37
ReporterVladAtWorkAssigned ToDrKnS 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Platform x64OSWindows 10OS Version10240
Product Version3.0 
Target VersionFixed in Version 
Summary0003106: Crash when execute FindInFiles using All standard code pages
DescriptionLast 3 builds when I search in source code and use All standard code pages FAR will crash almost every single time.
It looks like build version 3.0 (build 4242) x64 works fine but everything after does not.
Now I'm using version 3.0 (build 4444) x86 and issue is till there.

I used FindInFiles a lot and for me it is really important. Now I can to change to ANSI code page but sometimes information IS in different code page so I had to use other tools for this and they suck.
Steps To ReproduceCheckout https://github.com/dotnet/roslyn.git
Open find in files
Mask: *.*
Text: EPDM
All standard code pages
Crash:
Exception: Access violation (read from 0x03C1700B)
Address: 0x006185A4
Function: FindFiles::ThreadRoutine
Module: C:\Bin\Far\Far.exe

I did it 2 times and every time it crashes in the same place
TagsNo tags attached.
Build0

Relationships

duplicate of 0003047 closedDrKnS Исключение при поиске файла в режиме "Все стандартные кодовые страницы" 
duplicate of 0003026 closedDrKnS FindFiles access violation exception 

Activities

DrKnS

2015-10-27 02:37

administrator   bugnote:0014023

Duplicate of #3026. Post your feedback there, if any.

4447.

Issue History

Date Modified Username Field Change
2015-10-26 21:09 VladAtWork New Issue
2015-10-26 21:11 shmuel Relationship added duplicate of 0003047
2015-10-27 02:25 DrKnS Relationship added duplicate of 0003026
2015-10-27 02:37 DrKnS Build => 0
2015-10-27 02:37 DrKnS Note Added: 0014023
2015-10-27 02:37 DrKnS Status new => closed
2015-10-27 02:37 DrKnS Assigned To => DrKnS
2015-10-27 02:37 DrKnS Resolution open => duplicate