View Issue Details

IDProjectCategoryView StatusLast Update
0003229Far ManagerDrive Menupublic2016-05-08 11:50
Reporterkirill.kovalenkoAssigned ToDrKnS 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindownOS Version10
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0003229: Removing mounted VHDX files from the drive menu makes file locked
DescriptionUsing the drive menu I unmount a mounted VHDX file by pressing Del. The drive unmounts successfully, but further operations (move, delete, mount) with the VHDX file in question are not possible until I close the FAR instance I used to for the unmount operaiton.

I suspect some kind of handle is not being closed properly after unmount operation.
Steps To Reproduce1) Create a VHD/VHDX file. New-VHD -Path 'c:\farbug.vhdx' -SizeBytes 1gb -Fixed
2) Mount it. Mount-DiskImage -ImagePath 'c:\farbug.vhdx'
3) Create partition and format it.
$image = Get-DiskImage -ImagePath $path
Initialize-Disk -Number $image.Number -PartitionStyle MBR
New-Partition -DiskNumber $image.Number -UseMaximumSize -DriveLetter T | Format-Volume -FileSystem NTFS -Confirm:$false
4) Open FAR, Go to the drive menu, select the corresponding disk letter. Press Delete. Confirm deletion.
5) Try deleting the VHD/VHDX. You cannot, because the file is being locked by system.
6) Close FAR instance. Open it again.
7) Now you can delete the file.
TagsNo tags attached.
Build4659

Activities

DrKnS

2016-05-03 13:52

administrator   bugnote:0014527

4659

Issue History

Date Modified Username Field Change
2016-05-03 13:01 kirill.kovalenko New Issue
2016-05-03 13:37 DrKnS Assigned To => DrKnS
2016-05-03 13:37 DrKnS Status new => assigned
2016-05-03 13:52 DrKnS Note Added: 0014527
2016-05-03 13:52 DrKnS Status assigned => feedback
2016-05-08 11:50 DrKnS Build => 4659
2016-05-08 11:50 DrKnS Status feedback => closed
2016-05-08 11:50 DrKnS Resolution open => fixed
2016-05-08 11:50 DrKnS Fixed in Version => 3.0