View Issue Details

IDProjectCategoryView StatusLast Update
0003310Far ManagerPlugins APIpublic2016-09-25 20:10
ReporterpepakAssigned ToDrKnS 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0003310: PluginW.pas out of sync with plugin.hpp
DescriptionPluginW.pas is quite out of sync with plugin.hpp. A particularly nasty problem I ran into now was with sending values back to LUA's Plugin.Call() - it turns out that FarMacroCall.Callback is declared incorrectly in the .pas file (a missing argument), leading to crashes when the callback finishes. A file with this fix and several other added structures (only those I needed) is attached.
TagsNo tags attached.
Build4796

Activities

pepak

2016-09-24 11:09

reporter  

PluginW.pas.zip (21,472 bytes)

Issue History

Date Modified Username Field Change
2016-09-24 11:09 pepak New Issue
2016-09-24 11:09 pepak File Added: PluginW.pas.zip
2016-09-25 20:06 DrKnS Assigned To => DrKnS
2016-09-25 20:06 DrKnS Status new => assigned
2016-09-25 20:10 DrKnS Build => 4796
2016-09-25 20:10 DrKnS Status assigned => closed
2016-09-25 20:10 DrKnS Resolution open => fixed
2016-09-25 20:10 DrKnS Fixed in Version => 3.0