View Issue Details

IDProjectCategoryView StatusLast Update
0003618Far ManagerViewerpublic2018-07-03 23:06
ReporterDmitry GostevAssigned To2useven10 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformanyOSanyOS Versionany
Product Version3.0 
Target VersionFixed in Version 
Summary0003618: Feature 'view dump' annoys when watching mixed (binary/text) files
DescriptionWhen I open (F3) mixed files (binary+text logs) viewer jumps every time into 'Dump' mode, making hard to view the file. Every time I have to switch back to Text mode. Is it possible to disable this function completely or disable it switching automatically?
Steps To Reproduce1. Open file 444 in viewer.
2. Viewer goes into 'dump' mode.
demo file '444' is attached
TagsNo tags attached.
Build0

Relationships

has duplicate 0003627 closed2useven10 Текстовые файлы (логи) с 0x00 не показываются построчно, а "сплошным текстом" с разделителями ♪◙ 

Activities

Dmitry Gostev

2018-06-13 12:37

reporter  

444 (19,306 bytes)
444 (19,306 bytes)

shmuel

2018-06-13 12:50

developer   bugnote:0016134

One quick solution would be to use a macro like this:
Macro {
  area="Shell"; key="F3"; flags="NoFolders";
  action=function() Keys("F3 ShiftF4 Home Enter") end;
}

Issue History

Date Modified Username Field Change
2018-06-13 12:37 Dmitry Gostev New Issue
2018-06-13 12:37 Dmitry Gostev File Added: 444
2018-06-13 12:50 shmuel Note Added: 0016134
2018-07-03 11:26 shmuel Relationship added has duplicate 0003627
2018-07-03 17:43 JohnDoe Relationship replaced duplicate of 0003627
2018-07-03 17:47 JohnDoe Relationship deleted 0003627
2018-07-03 17:47 JohnDoe Relationship added related to 0003627
2018-07-03 23:04 2useven10 Relationship replaced has duplicate 0003627
2018-07-03 23:06 2useven10 Assigned To => 2useven10
2018-07-03 23:06 2useven10 Status new => closed
2018-07-03 23:06 2useven10 Resolution open => won't fix
2018-07-03 23:06 2useven10 Build => 0