View Issue Details

IDProjectCategoryView StatusLast Update
0003727Far ManagerFile Systempublic2019-08-07 20:04
ReporterSpireAssigned ToDrKnS 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version10
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0003727: Unnecessary elevation prompt when navigating to directory containing item(s) needing elevation for read access
DescriptionBeginning with this commit, which was first released in build 5441, if a user enables the “Request administrator rights: for read” option and then navigates to a directory containing one or more files or subdirectories that need elevation for read access, the user is unnecessarily prompted for elevation. If the directory contains more than one such item, Far Manager prompts the user for each individual item.

The expected behavior is to prompt the user for elevation only when accessing the actual item (e.g., viewing a file or navigating into a subdirectory) that needs elevation for read access, and not the parent directory.
Steps To Reproduce
  1. Launch Far Manager as a regular user.
  2. Go go “Options” → “System Settings” and enable the “Request administrator rights: for read” checkbox.
  3. Navigate to “C:\”, which contains the “System Volume Information” directory.
  4. Observe that Far Manager prompts for elevation.
TagsNo tags attached.
Build5445

Activities

Spire

2019-08-07 02:50

reporter   bugnote:0016554

I just realized after some more experimentation that I inadvertently omitted a crucial piece of information:

The unnecessary elevation prompt occurs only if the current file panel mode includes the “LN” (number of hard links) column type.

DrKnS

2019-08-07 02:51

administrator   bugnote:0016555

Last edited: 2019-08-07 02:52

View 2 revisions

> only when accessing the actual item

The mentioned commit also added support for elevation when requesting file owners.
Indeed, we don't want that when reading a directory so I've added a suppression in 5445.

Just in case - I recommend that you make sure that you really intended to show file owners and didn't enable them accidentally - it's a relatively expensive operation.

Spire

2019-08-07 04:51

reporter   bugnote:0016560

Ah yes, my mistake. It was triggering on file owners, not number of links. Thanks for adding the suppression.

Thanks also for letting me know that enabling file owners is relatively expensive. I do have them enabled by default, but I haven't felt any performance problems. Perhaps this just isn't an issue on a sufficiently fast system.

Spire

2019-08-07 19:04

reporter   bugnote:0016561

Confirming that it's fixed in build 5445.

Issue History

Date Modified Username Field Change
2019-08-07 02:07 Spire New Issue
2019-08-07 02:50 Spire Note Added: 0016554
2019-08-07 02:51 DrKnS Assigned To => DrKnS
2019-08-07 02:51 DrKnS Status new => feedback
2019-08-07 02:51 DrKnS Note Added: 0016555
2019-08-07 02:52 DrKnS Note Edited: 0016555 View Revisions
2019-08-07 04:51 Spire Note Added: 0016560
2019-08-07 04:51 Spire Status feedback => assigned
2019-08-07 19:04 Spire Note Added: 0016561
2019-08-07 20:04 DrKnS Status assigned => closed
2019-08-07 20:04 DrKnS Resolution open => fixed
2019-08-07 20:04 DrKnS Fixed in Version => 3.0
2019-08-07 20:04 DrKnS Build => 5445