View Issue Details

IDProjectCategoryView StatusLast Update
0000479PluginsMultiArc (old)public2008-03-08 09:46
ReporterujosAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.80 
Target VersionFixed in Version1.71 
Summary0000479: Cannot compile plugin in Debug mode
DescriptionRequired file printint.c is absent in fardev\plugins\multiarc\libpcre\.

Steps to reproduce:
Start compilation from plugins directory:
nmake -fmakefile_all_vc DEBUG=1

Expected:
All plugins are compiled

In fact:
Compilation process is stopped with the following message:

get.c
pcre.c
libpcre\pcre.c(435) : fatal error C1083: Cannot open include file: 'printint.c': No such file or directory
study.c
Generating Code...
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio 8\VC\BIN\cl.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
TagsNo tags attached.

Activities

ujos

2008-03-07 18:18

reporter   bugnote:0001209

MSVS 2005 SP1

alexy

2008-03-08 07:34

administrator   bugnote:0001228

fixed. disabled debug for libpcre as it is not needed.

ujos

2008-03-08 08:41

reporter   bugnote:0001233

Did you disabled multiarc|WIDE|DEBUG configuration at all?

alexy

2008-03-08 09:05

administrator   bugnote:0001234

Only for libpcre, check the diffs.

ujos

2008-03-08 09:40

reporter   bugnote:0001235

Looks like I compiled ANSI-debug version of multiarc. But I supposed that I build Unicode-Debug.

OK. ANSI-debug compiled succeffuly. Thanks.

Issue History

Date Modified Username Field Change
2008-03-07 18:17 ujos New Issue
2008-03-07 18:18 ujos Note Added: 0001209
2008-03-08 07:32 alexy Status new => assigned
2008-03-08 07:32 alexy Assigned To => alexy
2008-03-08 07:34 alexy Note Added: 0001228
2008-03-08 07:34 alexy Status assigned => feedback
2008-03-08 08:41 ujos Note Added: 0001233
2008-03-08 09:05 alexy Note Added: 0001234
2008-03-08 09:40 ujos Note Added: 0001235
2008-03-08 09:40 ujos Status feedback => resolved
2008-03-08 09:40 ujos Resolution open => fixed
2008-03-08 09:46 alexy Status resolved => closed
2008-03-08 09:46 alexy Fixed in Version => 1.71
2013-05-21 00:38 alexy Category MultiArc => MultiArc (old)