View Issue Details

IDProjectCategoryView StatusLast Update
0000480PluginsNetworkpublic2008-03-08 06:24
ReporterujosAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.80 
Target VersionFixed in Version1.80 
Summary0000480: Cannot build network plugin from vs2005
DescriptionWhen I start build UNICODE version of plugins I get following message:

NetNT.cpp(50) : error C2664: 'lstrcpynW' : cannot convert parameter 2 from 'LPSTR' to 'LPCWSTR'


Steps to reproduce:
From plugins directory start:
nmake -fmakefile_all_vc WIDE=1

Expected:
All plugins are compiled

In fact:
I get followig message:

NetNT.cpp(50) : error C2664: 'lstrcpynW' : cannot convert parameter 2 from 'LPSTR' to 'LPCWSTR'
        Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast
NetReg.cpp
Generating Code...
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio 8\VC\BIN\cl.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"D:\Program Files\Microsoft Visual Studio 8\VC\BIN\nmake.exe"' : return code '0x2'
Stop.
TagsNo tags attached.

Activities

ujos

2008-03-07 18:56

reporter   bugnote:0001210

MSVC 2005 SP1

ujos

2008-03-07 18:58

reporter   bugnote:0001211

PSHARE_INFO_1::shi1_netname is declared as LMSTR. LMSTR depends on platform. Look like _WIN32_WINNT should be defined.

//
// Only the UNICODE version of the LM APIs are available on NT.
// Non-UNICODE version on other platforms
//
#if defined( _WIN32_WINNT ) || defined( WINNT ) || defined( __midl ) \
    || defined( FORCE_UNICODE )
#define LMSTR LPWSTR
#define LMCSTR LPCWSTR
#else
#define LMSTR LPSTR
#define LMCSTR LPCSTR
#endif

alexy

2008-03-07 20:00

administrator   bugnote:0001214

fixed, for all plugins at once as I am really tired of this "bug" report.

Issue History

Date Modified Username Field Change
2008-03-07 18:46 ujos New Issue
2008-03-07 18:46 ujos Status new => assigned
2008-03-07 18:46 ujos Assigned To => Karbazol
2008-03-07 18:56 ujos Note Added: 0001210
2008-03-07 18:58 ujos Note Added: 0001211
2008-03-07 19:23 DrKnS Relationship added duplicate of 0000371
2008-03-07 19:59 alexy Assigned To Karbazol => alexy
2008-03-07 19:59 alexy Relationship deleted 0000371
2008-03-07 20:00 alexy Note Added: 0001214
2008-03-07 20:00 alexy Status assigned => feedback
2008-03-08 06:18 ujos Status feedback => resolved
2008-03-08 06:18 ujos Resolution open => fixed
2008-03-08 06:24 alexy Status resolved => closed
2008-03-08 06:24 alexy Fixed in Version => 1.80