View Issue Details

IDProjectCategoryView StatusLast Update
0000680Far Manager 1.7xMacropublic2008-12-25 15:29
ReporterNTLeeHentAssigned Tovskirdin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.75 
Target VersionFixed in Version1.75 
Summary0000680: $SelWord sets Selected flag on, even though no selection was made
DescriptionInside Editor, calling $SelWord when cursor is outside a word does not select anything - that is OK. Not Ok is that Selected flag is set nevertheless.

To reproduce:
1.Open a file with editor
2.Assign the macro below to a key using Macroview plugin
3.Set cursor somewhere *outside a word*, blank space
4.Run the macro


Macro:$SelWord $If (Selected) "Considered Selection" $End



TagsNo tags attached.
Build2494

Activities

vskirdin

2008-12-24 12:58

administrator   bugnote:0002240

test: http://ifolder.ru/9717211

NTLeeHent

2008-12-24 13:35

reporter   bugnote:0002241

Last edited: 2008-12-24 13:39

looks like fixed :)
thanks-thanks-thanks
which build is it supposed to be included to, please?

vskirdin

2008-12-24 13:53

administrator   bugnote:0002242

FAR 2494/688

Issue History

Date Modified Username Field Change
2008-12-24 10:47 NTLeeHent New Issue
2008-12-24 10:47 NTLeeHent Status new => assigned
2008-12-24 10:47 NTLeeHent Assigned To => vskirdin
2008-12-24 12:58 vskirdin Note Added: 0002240
2008-12-24 12:58 vskirdin Status assigned => feedback
2008-12-24 13:35 NTLeeHent Note Added: 0002241
2008-12-24 13:39 NTLeeHent Note Edited: 0002241
2008-12-24 13:53 vskirdin Note Added: 0002242
2008-12-25 14:44 NTLeeHent Status feedback => resolved
2008-12-25 14:44 NTLeeHent Resolution open => fixed
2008-12-25 15:29 vskirdin Build => 2494
2008-12-25 15:29 vskirdin Status resolved => closed
2008-12-25 15:29 vskirdin Fixed in Version => 1.75