View Issue Details

IDProjectCategoryView StatusLast Update
0000687Far Manager 1.7xPanelpublic2009-05-02 10:06
ReporterGammaAssigned Tovskirdin 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.75 
Target VersionFixed in Version1.75 
Summary0000687: Panel view is corrupted after Find folder
DescriptionProblem with panel update (with both Win2000 and Win98): If the Tree.Cache directory does not exist in the FAR directory, after Pressing Alt-F10 and exit 'Find folder' window, the panel is corrupted (file names and colors).


Original                 After Alt-F10/Esc        Re-Read
--------                 -----------------        ---------------------
Addons                   Addons                   Addons
Documentation            Documentation            Documentation
Plugins                  Plugins                  Plugins
PluginSDK                PluginSDK                PluginSDK
ClearPluginsCache.bat    TrearPluginsCache.bat    Tree.Cache
Descript.ion             Clecript.ion             ClearPluginsCache.bat
Far.bat                  Des.bat                  Descript.ion
Far.exe                  Far.exe                  Far.bat
Far.ico                  Far.ico                  Far.exe
Far.PIF                  Far.PIF                  Far.ico
Far.Site.txt             Far.Site.txt             Far.PIF
FarEng.hlf               FarEng.hlf               Far.Site.txt
FarEng.lng               FarEng.lng               FarEng.hlf
FarRus.hlf               FarRus.hlf               FarEng.lng
FarRus.lng               FarRus.lng               FarRus.hlf
File_id.diz              Fare_id.diz              FarRus.lng
License.txt              Filense.txt              File_id.diz
License.xUSSR.txt        License.xUSSR.txt        License.txt
readme.txt               Licdme.txt               License.xUSSR.txt
register.frm             reaister.frm             readme.txt
register.txt             register.txt             register.frm
RestoreSettings.bat      regtoreSettings.bat      register.txt
SaveSettings.bat         ReseSettings.bat         RestoreSettings.bat
Uninstall.exe            Savnstall.exe            SaveSettings.bat
uninstall.log            Uninstall.log            Uninstall.exe
                         uni                      uninstall.log


Other example
-------------
Tree.Cache
1  arPluginsCache
2  cript.ion
Cle.exe
Des.ico


Same issue if another process creates files etc.

May be introduced with the possibility to maximize 'Find folder' window by pressing F5: FIRST the new directory is listed in the panel and THEN the saved text (and colours) below the Find folder window area is restored, should be the other way round.
TagsNo tags attached.
Build2570

Activities

vskirdin

2009-04-29 22:21

administrator   bugnote:0003072

1.75 => build 2570
2.00 => build 892

Gamma

2009-04-30 00:51

reporter   bugnote:0003075

Valentin, what kind of feedback do you expect?

Just downloaded the lastest nightly build from Apr. 29. The bug is still there but the build number is 1.75 RC build 2568 x86. Therefore I will try again if the Build 2570 is available.

Or do you need more input data?

alexy

2009-04-30 00:57

administrator   bugnote:0003076

Expected feedback is for you to set the status of the ticket to resolved when you verify that the mentioned builds no longer have the issue.

Gamma

2009-04-30 01:59

reporter   bugnote:0003077

This will not be possible. The only version I can test is V1.75, because I to not have and will not install the (unicode) version 2.0.

alexy

2009-04-30 07:11

administrator   bugnote:0003078

Testing only 1.75 in this case is enough.

Gamma

2009-04-30 20:19

reporter   bugnote:0003082

The issues seem to be fixed, tested with FAR 1.75 RC build 2570 x86 under Win98 and Win2000

Issue History

Date Modified Username Field Change
2008-12-28 00:50 Gamma New Issue
2009-04-29 22:20 vskirdin Status new => assigned
2009-04-29 22:20 vskirdin Assigned To => vskirdin
2009-04-29 22:21 vskirdin Note Added: 0003072
2009-04-29 22:21 vskirdin Status assigned => feedback
2009-04-30 00:51 Gamma Note Added: 0003075
2009-04-30 00:57 alexy Note Added: 0003076
2009-04-30 01:59 Gamma Note Added: 0003077
2009-04-30 07:11 alexy Note Added: 0003078
2009-04-30 20:19 Gamma Note Added: 0003082
2009-04-30 20:19 Gamma Status feedback => resolved
2009-04-30 20:19 Gamma Resolution open => fixed
2009-05-02 10:06 vskirdin Build => 2570
2009-05-02 10:06 vskirdin Status resolved => closed
2009-05-02 10:06 vskirdin Fixed in Version => 1.75