View Issue Details

IDProjectCategoryView StatusLast Update
0000854Far ManagerViewerpublic2009-05-05 10:20
Reporteralexmitin Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSWindows 
Summary0000854: Hex view shows wrong hex values for the UTF-8 encoded files
DescriptionThe hex view shows wrong hex values.
Steps To Reproduce1) Open any of the following files in the internal viewer (F3 or Alt+F3):

  FarCze.lng
  FarEng.lng
  FarGer.lng
  FarHun.lng
  FarPol.lng
  FarRus.lng

Note: these files are from the night builds. They all have UTF-8 encoding.

2) Switch to hex view (F4). The text on the right is OK. However the hex values are wrong. All hex values are 0xBA.

3) Press F4 twice. The hex values change to 0x00.

4) Scroll down (PgDn). Some hex values are still 0x00, some are 0xBA.
TagsNo tags attached.
Build0

Relationships

duplicate of 0000752 closedalexy hex view on utf8 files shows each byte as 0x00 

Activities

vskirdin

2009-05-05 10:20

administrator   bugnote:0003110

В общем тут есть такое (цитата):

"А зачем в Viewer::ShowHex() вызывается вот это:
WideCharToMultiByte(VM.CodePage, 0, (const wchar_t*)&Ch,1, &NewCh,1," ",NULL);
после чего печатается 16-ричный код NewCh (который для файлв в utf8
может принимать любое значение, зависящее от положения луны, погодных
условий и пр.)"

возможно это и лечение.
"возможно" - потому, что пока не пойму на что оно может повлиять.

alexmitin: закомменть эту строку и попытайся "исследовать" на что оно повлияет :-)

Issue History

Date Modified Username Field Change
2009-05-05 01:50 alexmitin New Issue
2009-05-05 10:11 vskirdin Relationship added duplicate of 0000752
2009-05-05 10:13 alexy Build => 0
2009-05-05 10:13 alexy Status new => closed
2009-05-05 10:13 alexy Resolution open => duplicate
2009-05-05 10:20 vskirdin Note Added: 0003110