View Issue Details

IDProjectCategoryView StatusLast Update
0003185Far ManagerPanelpublic2016-02-23 20:49
ReporterJargonAssigned ToDrKnS 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx64OSWindowsOS Version7
Product Version3.0 
Target VersionFixed in Version3.0 
Summary0003185: Panel in unsorted mode is showing the first file/folder as the last
DescriptionBoth the latest stable build (4545) and the latest nightly build (4559) are displaying the files/folders in the wrong sorting order in unsorted mode. The first file/folder is being displayed as the last item in the panel. For example, if a folder contains the files A, B, C, D and E (in actual order), Far Manager in unsorted mode will list the files as B, C, D, E and A (file A is in the wrong place).
Steps To ReproduceSe Far manager to unsorted (Ctrl-F7). Then navigate to any folder with multiple files or folders and check the order that the files/folders are displayed on the panel. Enter the command "dir" on the command line. Compare the sorting order of the "dir" command with the sorting order of Far Manager. They are supposed to be the same but they are not because Far Manager is displaying the files/folders in the wrong order.
TagsNo tags attached.
Build4560

Activities

shmuel

2016-02-23 18:02

developer   bugnote:0014333

Jargon wrote

the wrong sorting order in unsorted mode

As far as I understand, the order in the "unsorted mode" can not be right or wrong. It is not specified in the Help what order should be in that mode. It also does not have to be the same as with dir command. The only thing that is clear is that no sorting operations are performed.

DrKnS

2016-02-23 20:49

administrator   bugnote:0014334

Nevertheless it's a bug.

4560.

Issue History

Date Modified Username Field Change
2016-02-23 14:57 Jargon New Issue
2016-02-23 18:02 shmuel Note Added: 0014333
2016-02-23 20:46 DrKnS Assigned To => DrKnS
2016-02-23 20:46 DrKnS Status new => assigned
2016-02-23 20:49 DrKnS Build => 4560
2016-02-23 20:49 DrKnS Note Added: 0014334
2016-02-23 20:49 DrKnS Status assigned => closed
2016-02-23 20:49 DrKnS Resolution open => fixed
2016-02-23 20:49 DrKnS Fixed in Version => 3.0